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Category: Problem

Priority: Critical

Platform: Splunk Cloud

Version: 1 from 10.03.2023

Description

Dropdowns using the master_inventory_lookup do not populate in the PowerConnect App for Splunk dashboards in Splunk Cloud environments.

Cause

The Master Inventory Lookup is KVstore based. A Splunk Cloud bug is causing the supported fields list in the lookup definition to be misinterpreted, resulting in the lookup showing no results in search despite data being present in the underlying KV collection.

Resolution

As a temporary workaround, this lookup should be converted to a CSV file-based lookup:

...

After the search concludes please proceed to any of the dashboards within the PowerConnect Splunk app. The dropdowns will now work as designed. But If still the SID is not getting populated on Splunk Cloud , the below additional setting needs to be performed

On Splunk's menu bar, Click on Search -> Advanced search -> Search Macros  -> search term (sap-index)

Before:

...

Removed the double quotes and changed to the index which is defined (In our case index=sap) and then run Post configuration wizard setup again.

 

After:

...