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KB 116 - Locked User Stopping PowerConnect Data Extraction

KB 116 (ABAP) - Locked User Stopping PowerConnect Data Extraction

Category: Problem

Priority: Normal

Category: Problem

Priority: Normal

Platform: ABAP

Version: 1 from 23.03.2021

Description

If the user executing the PowerConnect batch jobs in the managed environment is locked, there will be a number of metric errors generated, and the data extraction jobs will not perform their intended function. This means that new data will not be collected and sent to Splunk. The metric errors can be viewed by following the steps below:

  • Log into the environment where the PowerConnect agent is installed and execute the /n/bnwvs/main transaction.

  • If there are metric errors, they will be visible on the right side of the screen.

  • Then click on Administrator → Check Errors

  • The metric errors associated with the user being locked will look like this:

Cause

The PowerConnect application has an internal mechanism that will stop the extractor job from extracting new data if this error message is identified. This functionality exists to prevent a significant amount of metric errors from being generated in the environment.

Resolution

Important Note: This issue primarily occurs due to the user being locked for system maintenance activities. The best way to avoid this issue is to place the user responsible for executing the PowerConnect jobs in an exclusion group where it is not locked during system maintenance.

To fix this issue, first unlock the user that is responsible for using the PowerConnect batch jobs. Once you have confirmed that the user is unlocked, complete the steps below:

  • Log into the environment where the PowerConnect agent is installed and execute the /n/bnwvs/main transaction.

  • Stop the PowerConnect batch jobs using the buttons below.

  • Confirm the batch jobs have stopped running. The PowerConnect administrative console should look like this.

  • Then go to Administrator → Check Errors

  • Click on the Fixed box next to the metric errors associated with the user being locked. Save.

  • Return to the PowerConnect administrative console main page. Then restart the PowerConnect batch jobs using the buttons below:

  • The PowerConnect administrative console should match the screen below once the batch jobs have successfully restarted.

  • You will then see the PowerConnect jobs begin to collect and send data to Splunk. Additionally, the metric errors in the PowerConnect administrative console should clear.

 

Product

From

To

PowerConnect [NW,S4HANA,S4HANA Cloud]

[Affected version from]

[Affected version to]